Kraken UAT - Degraded Performance

Incident Report for Payward Services Sandbox

Resolved

This incident has been resolved.
Posted Aug 21, 2026 - 12:43 UTC

Monitoring

Incident status updated.
Posted Aug 21, 2026 - 12:42 UTC

Identified

Incident status updated.
Posted Aug 20, 2026 - 14:37 UTC

Investigating

Some clients may be unable to view portfolio history for dates from August 6 onward. Current balances and trading are not indicated as affected.
Posted Aug 20, 2026 - 14:15 UTC