Kraken UAT - Degraded Performance

Incident Report for Payward Services Sandbox

Resolved

This incident has been resolved.
Posted Aug 26, 2026 - 09:27 UTC

Monitoring

Incident status updated.
Posted Aug 26, 2026 - 09:26 UTC

Identified

Incident status updated.
Posted Aug 26, 2026 - 08:40 UTC

Investigating

Users may be unable to place or manage spot trades in the testing environment. Existing account balances are not expected to be impacted.
Posted Aug 26, 2026 - 08:23 UTC