Kraken UAT - Degraded Performance

Incident Report for Payward Services Sandbox

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 08:02 UTC

Monitoring

Incident status updated.
Posted Jul 08, 2026 - 08:01 UTC

Identified

Incident status updated.
Posted Jul 07, 2026 - 20:18 UTC

Investigating

Clients may be experiencing issues logging in to their accounts. Other services including trading and account management are not affected.
Posted Jul 07, 2026 - 19:28 UTC