Kraken UAT - Degraded Performance

Incident Report for Payward Services Sandbox

Resolved

This incident has been resolved.
Posted Jun 29, 2026 - 11:33 UTC

Update

Incident status updated.
Posted Jun 29, 2026 - 11:04 UTC

Investigating

Clients may be experiencing connectivity issues with the trading platform, including unavailability of market data, trading, and portfolio views. Some users may be unable to place orders or view their portfolio positions.
Posted Jun 29, 2026 - 10:43 UTC