Kraken UAT - Degraded Performance

Incident Report for Payward Services Sandbox

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 07:19 UTC

Investigating

We are currently investigating this issue and will provide more information shortly.
Posted Aug 20, 2026 - 04:45 UTC