Kraken UAT - Degraded Performance

Incident Report for Payward Services Sandbox

Resolved

This incident has been resolved.
Posted Jul 07, 2026 - 09:43 UTC

Identified

Incident status updated.
Posted Jul 07, 2026 - 08:16 UTC

Investigating

Clients may be unable to access order book data for tokenized equity assets. Other trading functions and asset types are not affected.
Posted Jul 07, 2026 - 07:56 UTC